Российские маршрутизаторы Qtech, как замена Cisco

  • 07.02.2023
  • 764

Автор
Сергей Калашников, CCIE

Технический директор


Оглавление

После ухода с нашего рынка компании Cisco, достаточно часто встаёт вопрос: что использовать взамен? В плане коммутаторов больших вопросов обычно нет. Функциональность и аппаратные характеристики этих устройств плюс-минус одинаковые. Но когда дело касается маршрутизаторов, замена становится нетривиальной. Нужно учесть ряд важных факторов. Именно поэтому специалисты компании CBS, в рамках цикла кратких технических обзоров, подготовили пример, который позволит разобраться, возможно ли заменить маршрутизаторы Cisco на маршрутизаторы Qtech для определенной задачи.

Задача: необходимо заменить маршрутизатор Cisco, выполняющий роль пограничного BGP-устройства.

Аппаратная часть

В выборе платформы мы должны определиться с требования по портам (сколько и каких) и производительностью. Продуктовая линейка маршрутизаторов Qtech не самая большая – всего четыре модели. Но предложения в плане портов и производительности достаточно широкие, одна из моделей модульная.

Для нашей задачи ещё одни фактором является ОЗУ. Если мы собираемся получать от провайдера полную таблицу маршрутизации, то все эти маршруты должны поместиться в памяти устройства. В плане маршрутизаторов Qtech мы становимся перед выбором: или получать полную таблицу маршрутизации и использовать старшую модель маршрутизатора (QSR-3920), или согласиться на маршрут по умолчанию и существенно сэкономить на платформе. В большинстве случаев достаточно маршрута по умолчанию.

Программная часть

Для реализации поставленной задачи формально нам потребуется поддержка следующих протоколов: BGPv4 и VRRP. Оба протокола поддерживаются маршрутизаторами Qtech. Но нужно смотреть более предметно по каждой функции в рамках этих протоколов. Для этого потребуется анализ документации по настройке, так как общее техническое описание таких нюансов не содержит. И вот тут Qtech оказывается достаточно функциональным. Есть гранулярная фильтрация входящих и исходящих префиксов, установка различных атрибутов BGP и пр.

Настройка маршрутизаторов Qtech

С точки зрения командной строки (CLI), конфигурация Qtech очень напоминает Cisco. Многие команды можно копировать один в один. Ниже приведем выдержки из конфигурации.

Настройки внешнего интерфейса

interface gigabitethernet0
 description == ISP1 ==
 ip address 127.0.0.2 255.255.255.192
 media-type copper
 exit

Настройки внутреннего интерфейса

interface gigabitethernet1
 description == Inside ==
 ip address 77.77.77.254 255.255.255.0
 media-type copper
 vrrp 1 ip 77.77.77.1
 vrrp 1 priority 110
 vrrp 1 authentication text KEY_01
 vrrp 1 track gigabitethernet0 20
 exit

Route-map для фильтрации маршрутов

ip prefix-list default-route seq 5 permit 0.0.0.0/0

route-map as-22222-incoming permit 5
 match ip address prefix-list default-route
 set local-preference 110
 exit

ip prefix-list own-net seq 5 permit 77.77.77.0/24

route-map as-22222-outgoing permit 5
 match ip address prefix-list own-net
 exit

Настройки BGP

router bgp 11111
 no auto-summary
 no synchronization
 network 77.77.77.0 255.255.255.0
 neighbor 77.77.77.253 remote-as 11111
 neighbor 77.77.77.253 description BGP-router-2
 neighbor 77.77.77.253 next-hop-self
 neighbor 127.0.0.1 remote-as 22222
 neighbor 127.0.0.1 description ISP1
 neighbor 127.0.0.1 route-map as-22222-incoming in
 neighbor 127.0.0.1 route-map as-22222-outgoing out
 exit

Все основные параметры, необходимые при настройке протокола BGP, на маршрутизаторах Qtech присутствуют: фильтрация через prefix-list, выставление значений Local Preference и пр. Аналогичная ситуация с отладочными командами (show и debug).

Безусловно функциональность Qtech проигрывает Cisco. Например, на Qtech нет возможности анонсирования префиксов в зависимости от условий (Conditional Advertisement). Но для большинства инсталляций доступной функциональности достаточно.

Техническая поддержка Qtech

В процессе настройки возникла пара вопросов, которые были очень оперативно решены через портал поддержки вендора. Этот момент приятно удивил.

Вывод

Маршрутизаторы Qtech во многих задачах могут стать хорошей заменой оборудованию Cisco. Большим плюсом будет возможность переноса конфигурация с незначительными изменениями и привычным отладочным синтаксисом.

Если у Вас остались вопросы по вариантам замены оборудования Cisco на оборудование Qtech или других российских производителей, обязательно пишите нам на почту cbs@cbs.ru или звоните по номеру +7 495 411 82 82. Наши специалисты обладают высокой квалификацией и большим опытом технической экспертизы, что позволяет подбирать неизбыточные решения конкретно под вашу задачу.

Список литературы
  1. Маршрутизаторы Qtech для корпоративных сетей
  2. Документация по настройке маршрутизаторов Qtech
Возможно, вас заинтересует
  1. Подключение к интернет-провайдеру : проблемы и решения
  2. Реализация автосекретаря на базе решений компании Cisco
  3. Методы оптимизации приема/передачи в сетях Wi-Fi
  4. Оптимизация передачи multicast-трафика в локальной сети с помощью IGMP snooping
  5. Rapid STP